NextGen Application version 5.8 Upgrade

Project Overview

Featured Downloads

 Enterprise Initiatives

Other Upcoming Upgrades

The version 5.8 upgrade allows Kootenai Health and its NextGen Enterprise System to become ICD-10 ready, SNOMED ready, and MU2 ready.

ICD-10 diagnosis codes are federally mandated. In order to process ICD-10 codes, Kootenai's Enterprise NextGen System must upgrade to an ICD-10 ready platform. The 5.8 version upgrade also provides necessary capture and reporting tools needed for Meaningful Use reporting. 

Go-Live Date: March 10, 2014

Affected Clients

This application version 5.8 upgrade primarily affects EPM users.  

Training Opportunities

Click here to access the training calendar.

Note: if this is your first time accessing the calendar, you may need to set up a username and password.

 

Customer Support

With questions regarding the upgrade, please contact the 24/7 Kootenai Health Help Desk.*

  1. By Phone: 855-554-4440 (toll free) or 208-625-5555
  2. By Email: helpdesk@kh.org

* To ensure your needs are directed appropriately, please specify to the team that your inquiry is in regards to the NextGen 5.8 upgrade.